优炫网络安全研究院:Struts2S2-062远程代码执行漏洞(CVE-2021-31805)

2022-04-24

()

 

一、概述

 

近日,优炫网络安全研究院监测到Apache官方发布了Apache Struts 2 的安全通告,漏洞编号:CVE-2021-31805,漏洞等级:高危,漏洞评分:8.5。

 

该漏洞的产生原因是一个更早漏洞CVE-2020-17530(S2-061)的修复不完全。当开发者使用%{…}语法进行强制OGNL评估时,某些标签属性仍然可被执行双重评估。当对标签属性中未经验证的原始用户输入进行解析时可能会导致远程代码执行。

 

Apache Struts 2是一个用于开发Java EE网络应用程序的开源Web框架,应用非常广泛。对此,优炫网络安全研究院建议广大用户及时将Apache Struts 2升级到最新版本。同时,请做好资产自查和漏洞防护工作,保障企业自身安全。

 

二、漏洞影响范围

 

l 受影响的版本:

2.0.0 ≤ Apache Struts ≤ 2.5.29

l 不受影响的版本:

Apache Struts ≥ 2.5.30

 

三、修复建议

 

1、版本升级

 

目前官方已发布新版本修复了此漏洞,请受影响的用户尽快更新进行防护,下载链接:https://struts.apache.org/download.cgi#struts-ga

 

2、临时防护措施

 

l 可通过设置所有标签中value=""来缓解此漏洞;

l 将org.apache.commons.collection.BeanMap添加至excludedClasses黑名单中。

 

四、澳门游戏平台注册网站-澳门游戏注册送彩金-首页解决方案

 

优炫下一代防火墙支持该漏洞防护,需要将特征库升级至20220419及以上版本。升级路径为:系统管理→系统维护→系统升级,点击立刻升级或者离线下载特征库手动升级。

 

 

防护后效果:特征库升级后,在策略中选用包含该特征的IPS模板,并配置记录日志和阻断。当攻击发生时,就会被优炫下一代防火墙拦截并记录日志。

 

XML 地图 | Sitemap 地图